?

Log in

No account? Create an account

Алло, мы ищем логических дизайнеров! - Ваши рубидии уже у кобальта во ртути

Oct. 12th, 2015

07:13 pm - Алло, мы ищем логических дизайнеров!

Previous Entry Share Next Entry

Comments:

[User Picture]
From:kcmamu
Date:October 18th, 2015 05:51 pm (UTC)
(Link)
Про 7 делается и умозрительно очевидным образом.

Сперва составляем схему из честных полусумматоров и полных сумматоров (A...L входы, Ui, Di, Qi внутренние переменные, относящиеся к разрядам единиц-двоек-четверок, {OO,QQ,DD,UU} выход):

{D1,U1} = HA(A,B)
{D2,U2} = FA(U1,C,D)
{D3,U3} = FA(U2,E,F)
{D4,U4} = FA(U3,G,H)
{D5,U5} = FA(U4,I,J)
{D6,UU} = FA(U5,K,L)
{Q1,D7} = HA(D1,D2)
{Q2,D8} = FA(D7,D3,D4)
{Q3,DD} = FA(D8,D5,D6)
{OO,QQ} = FA(Q1,Q2,Q3)

Теперь 1-й, 3-й и 5-й операторы расписываем отдельно для каждого выхода:

D1 = A&B
U1 = A^B
{D2,U2} = FA(U1,C,D)
D3 = MAJ(U2,E,F)
U3 = U2^E^F
{D4,U4} = FA(U3,G,H)
D5 = MAJ(U4,I,J)
U5 = U4^I^J
{D6,UU} = FA(U5,K,L)
{Q1,D7} = HA(D1,D2)
{Q2,D8} = FA(D7,D3,D4)
{Q3,DD} = FA(D8,D5,D6)
{OO,QQ} = FA(Q1,Q2,Q3)

И "вклеиваем" их туда, куда эти выходы подключаются:

{D2,U2} = FA(A^B,C,D)
{D4,U4} = FA(U2^E^F,G,H)
{D6,UU} = FA(U4^I^J,K,L)
{Q1,D7} = HA(A&B,D2)
{Q2,D8} = FA(D7,MAJ(U2,E,F),D4)
{Q3,DD} = FA(D8,MAJ(U4,I,J),D6)
{OO,QQ} = FA(Q1,Q2,Q3)

Получается 7 операций с 2 выходами и не более чем 5 входами.
(Reply) (Parent) (Thread)
[User Picture]
From:spamsink
Date:October 18th, 2015 07:32 pm (UTC)
(Link)
Я пользовался другим методом - видимо, потому, что начинал решать в уме. С помощью 7 операций, действительно, не очень сложно, но я заскриню.
(Reply) (Parent) (Thread)
[User Picture]
From:spamsink
Date:November 2nd, 2015 07:08 am (UTC)
(Link)
Я опубликовал ответ.
(Reply) (Parent) (Thread)